PHP Compilation ERROR “:configure: error: DBA: Could not find necessary header file(s).”

If you get this error at time when you are compiling PHP using “–with-gdbm”:

then you are probably missing the gdbm-devel package.

For redhat users # yum install gdbm-devel
For ubuntu users # apt-get install libgdbm-dev

Advertisements
This entry was posted in LAMP. Bookmark the permalink.

2 Responses to PHP Compilation ERROR “:configure: error: DBA: Could not find necessary header file(s).”

  1. NorB says:

    # apt-get install libgdbm-dev

    Helped for me on Ubuntu 8.04.2.

    Thanks ! 😉

  2. This isn’t only related to libgdbm-dev this can be related to any database and it’s development libraries example: db4. We compile –without-gdbm and got this error because it was a new system and we forgot to install the db4 dev’s.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s