Category Archives: LAMP

Related to APACHE, PHP & MYSQL with Linux…

server: /usr/local/apache2/modules/libphp5.so: cannot restore segment prot after reloc: Permission denied

Today I have faced a weired problem. I have compiled apache-php so many times till today. BUt havn’t faced this kind of problem. Installation of both packages were fine without any error. As soon as I completed installation, I stopped … Continue reading

Posted in LAMP, Linux | Tagged , , , , , , , | 2 Comments

PHP Compilation ERROR “:configure: error: DBA: Could not find necessary header file(s).”

If you get this error at time when you are compiling PHP using “–with-gdbm”: then you are probably missing the gdbm-devel package. For redhat users # yum install gdbm-devel For ubuntu users # apt-get install libgdbm-dev

Posted in LAMP | 2 Comments

MySQL dump & restore database

To take dump of any database use following. [root@superbox]#  mysqldump –opt databasename -p > databasedump.sql To restore existing dump to new database. * Login in mysql [root@superbox]# mysql -uroot -p * Create new database. mysql> create database <databasename>; * Create … Continue reading

Posted in LAMP | Leave a comment

Common Apache compilation problems on Linux servers

1) “/usr/lib/libexpat.so: could not read symbols: File in wrong format Solutions : #make clean # mv srclib/apr-util/configure srclib/apr-util/configure_old —- only in case of 64 bit os) # mv configure configure_old # ./buildconf Run config again. 2) “configure: error: mod_deflate has … Continue reading

Posted in LAMP | Leave a comment

Common PHP compilation problems on Linux servers

1) Configure: error: xml2-config not found. Please check your libxml2 installation. Solutions : Quote: #yum install libxml2 libxml2-devel (For Redhat & Fedora)# aptitude install libxml2-dev      (For ubuntu) 2) Checking for pkg-config… /usr/bin/pkg-config configure: error: Cannot find OpenSSL’s <evp.h> Solutions : … Continue reading

Posted in LAMP | 3 Comments

Libexpat Problem with Apache2 on 64 bit OS.

Libexpat Problem with Apache2 on 64 bit OS. If you get the following error while installing Apache2 on 64bit linux. /usr/lib/libexpat.so: could not read symbols: File in wrong format Solution: 1. Delete file ‘srclib/apr-util/configure’ under ‘httpd-2.0.61’ 2. Delete ‘configure’ file … Continue reading

Posted in LAMP | Leave a comment

Installing AWSTATS in Linux

This is my owned installation file…I used it n its working.. You guys also keep habit of maintaining installation file. Download installation from website 1. wget http://nchc.dl.sourceforge.net/sourceforge/awstats/awstats-6.7.tar.gz 2. tar -xvzf awstats-6.7.tar.gz 3. mv awstats-6.7 /usr/local/ 4. cd /usr/local/ 5. mv … Continue reading

Posted in LAMP, Linux | Leave a comment